Hilfe: Report-Designer

Mit dem Report-Designer können Sie das Aussehen der in Hyreka verwendeten Dokumente wie Rechnung, Agebote, Packliste , usw. nahezu beliebig anpassen. Der Designer bietet eine grafische Oberfläche in der z.B. Textobjekte verschoben, verändert, hinzugefügt oder gelöscht werden können.

Den Report-Designer können Sie über das Hauptmenü unter Warenwirtschaft - HYREKA II -> Report-Designer öffnen. Um die integrierten Standard-Vorlagen zu bearbeiten, lesen Sie den Abschnitt Dokumente bearbeiten.

Ein Report besteht aus einem oder mehreren Subreports. Subreports sind wiederum in Bereiche die sog. Bänder unterteilt. Die Bänder liegen untereinander im Arbeitsbereich und werden der Reihenfolge nach gerendert (dargestellt). Bänder können weitere Unterbereiche (Subreports) enthalten, sodass sich sehr komplexe Strukturen erzeugen lassen. Die eigentlichen Elemente befinden sich in den Bändern und können verändert werden. Die meisten Elemente enthalten nicht nur Text, sondern auch Daten aus der Datenbank und zusätzliche Bedingungen, die den Wert oder die Anzeige verändern können.

Report-Designer Benutzeroberfläche

Dokumente bearbeiten

Gehen Sie über das Hauptmenü Einstellungen -> Dokumentenvorlagen zu der gewünschten Vorlage, indem Sie die Vorlage aus dem Baum auswählen. Klicken Sie die Vorlage an. Sie haben nun die Möglichkeit die Vorlage in der Vorschau anzuzeigen, zu drucken und zu bearbeiten. Wenn Sie die Vorlage bearbeiten öffnet sich der Report-Designer und Sie können direkt Veränderungen vornehmen. Da sich die Reports im Verezeichnis der Datenbank befinden, betreffen die Änderungen alle Benutzer im Netzwerk.

Dokumentenvorlagen bearbeiten

Die Änderung an einem Dokument wirkt sich immer nur auf das selbige aus. Manche Änderungen müssen also in mehreren Dokumenten ausgeführt werden. Speichern Sie Ihre Änderungen, indem Sie auf das Symbol klicken.

Eine Ausnahme bilden der Kopf- und Fußbereich mit dem Logo und den Firmendaten. Diese Bereiche sind global in der Datenbank gespeichert und eine Änderung wirkt sich auf alle Dokumente aus. Wie Sie Kopf- und Fusszeile speichern, erfahren Sie im nächsten Kapitel.

Kopf- und Fußzeile global anpassen

Die Kopf- und Fußzeile sind in der Datenbank gespeichert, damit sich eine Änderung immer auf alle Dokumente auswirkt. Um eine Änderung auch permanent zu speichern, muss ein zusätzlicher Schritt erfolgen, "Speichern" alleine ist nicht ausreichend.

Kopf- und Fusszeile global anpassen

Nachdem Sie den Bereich agepasst haben, wählen Sie wie in den Screenshots dargestellt (1) den gesamten Kopf- oder Fussbereich aus. Anschließend klicken Sie mit der rechten Maustaste in das Feld (2) Ext. Datenbank. Klicken Sie nun auf (3) Bereich speichern. Durch diesen Vorgang wird die Änderung in der Datenbank gespeichert. Die Änderung ist nun in allen Dokumenten wirksam, die diesen Bereich ebenfalls verwenden.

Firmenlogo anpassen

Zunächst müssen Sie unter Einstellungen -> Firma Ihr Logo importieren. Nach dem Import wird das Logo in allen Dokumenten im Kopf angezeigt. In den Dokumenten ist eine Auflösung von 300 dpi voreingestellt, dies entspricht bei einer Bildbreite von 2480 Pixeln einer Druckbreite von 21cm (DIN A4). Liegt Ihr Bild in einer anderen Auflösung vor, wird es in der Vorschau und im Druck kleiner oder größer dargestellt. In diesem Fall können Sie die Auflösung in der Druckvorlage anpassen.

Bearbeiten Sie ein Dokument und markieren Sie das Logo im Bereich "Kopfzeile der Seite". In den Eigenschaften können Sie nun den Wert in Auflösung (dpi) verändern. Zudem können Sie das Logo-Element mit der Maus verschieben und verzerren. Wenn Sie die Position verändern möchten, muss zunächst die Größe (Breite) verringert werden, damit das Logo weiter nach rechts verschoben werden kann. Die Größe können Sie mit der Maus oder über die Eigenschaften (Breite, Höhe) anpassen.

Klicken Sie auf Vorschau um sich das Ergebnis anzeigen zu lassen. Vergessen Sie später nicht den Kopfbereich global zu speichern.

Firmenlogo anpassen

Anzeigeformat für Preise (Nachkommastellen, Tausendertrenner)

Die Formatierung (Zahlenformat) der Preisangaben können Sie über die Eigenschaft Anzeigeformat ändern. Sie können die Zifferngruppierung (Tausendertrenner) und die dargestellten Nachkommastellen steuern. Als Standardeinstellung werden die Nettovorlagen mit 4 und die Bruttovorlagen mit 2 Nachkommastellen angezeigt. Um das gewünschte Format einzustellen, markieren Sie das gewünschte Textfeld und ändern das Anzeigeformat im Reiter Bedingungen.

Formatierungen

  • 2-Nachkommastellen: ###,###,###0.00
  • 4-Nachkommastellen: ###,###,###0.0000

Anzeigeformat für Preise ändern

Seite und Druckbereich anpassen

Um die Papiergröße und die Seitenränder eines Dokuments anzupassen, klicken Sie auf Datei -> Seite einrichten. Nehmen Sie die gewünschten Änderungen vor und speichern Sie das Dokument. Die Änderung wirkt sich nur auf das aktuelle Dokument aus.

Seite und Druckbereich einrichten

Datum, Zeit und Seiten anzeigen

Über den Reiter Daten -> Variablen können Sie Systemvariablen, wie z.B. das aktuelle Datum oder die Seitenzahl, so wie benutzerdefinerte Variablen (Report-Parameter), in einen Report per Drag&Drop einfügen.

Variablen in ein Dokument einfügen

  • TODAY - Aktuelles Datum
  • TIME - Aktuelle Uhrzeit
  • NOW - Datum und Zeit
  • PAGE - Aktuelle Seitenzahl
  • PAGECOUNT - Gesamtzahl Seiten. Es handelt sich um eine spezielle Variable, die nicht mit anderen Variablen oder Werten kombiniert und in einer Formel verwendet werden kann. Damit die Gesamtzahl Seiten ermittelt werden kann, muss die Option Two pass report in den Seiteneinstellungen aktiviert werden. Die Option finden Sie im Menü unter Datei -> Seite einrichten -> Drucker einrichten.

Zusätzliche Datenfelder einfügen

Um weitere Datenfelder in ein Dokument einzufügen, klicken Sie in den Reiter Daten. Dort werden alle im Bericht zur Verfügung stehenden Abfragen und Felder angezeigt. Erweitern Sie eine Abfrage, um die zugehörigen Felder anzuzeigen. Nun können Sie ein Feld einfach in das Dokument ziehen und bearbeiten. In jedem Dokument stehen nur bestimmte Daten zur Verfügung. Wenn Sie zusätzliche Felder benötigen, fragen Sie unseren Kundenservice.

Zusätzliche Datenfelder in ein Dokument einfügen

Datenabfragen (SQL-Querys) einrichten

Um Daten aus der Datenbank abzufragen müssen sogenannte Querys eingerichtet werden. Ein Query ruft Daten durch die Datenbanksprache SQL ab. Durch eine SQL-Abfrage können Daten gefiltert, gruppiert und sortiert werden. Eine Abfrage kann von sehr einfach bis sehr komplex werden. Eine einfache Abfrage wäre z.B. SELECT * FROM artikel, um alle Artikel abzufragen.

SQL ist standardisiert und unterscheidet sich nur im Umfang abhängig vom Datenbanksystem. Umfassende Hilfe zur SQL-Syntax finden Sie im Internet.

SQL Datenabfragen einrichten

Klicken Sie in der Werkzeugleiste auf das Hammer-Symbol, um die Datenverbindungen zu öffnen. In den meisten Reports sind bereits Abfragen angelegt, aber Sie können auch eigene Querys hinzufügen. Jede Abfrage benötigt eine Datenbankverbindung. In Hyreka greift die Datenbank KUNDENMANAGER auf die globalen Daten zu.

Wählen Sie eine Abfrage aus, oder fügen Sie neue Querys hinzu. Es muss eine Datenverbindung zugewiesen und ein SQL-Befehl eingetragen werden. Mit Daten anzeigen können Sie die Abfrage überprüfen. Anschließend können Sie die Änderungen mit OK übernehmen. Der Query ist nun im Report unter Daten verfügbar.